Búsqueda FAQ
>   Seleccione idioma

Carga de un 'runtime' de versión anterior a la actual en terminales XBT-GT

Se dispone de una terminal XBTGT7XXX al cual se le cargó en su día una aplicación a través del Vijeo Designer v5.0. Ahora se pretende  cargarle una aplicación con la versión v4.6d del Vijeo Designer pero a la hora de realizar la operación aparece un mensaje de error según el cual el 'runtime' de la pantalla es posterior al que se intenta cargar, con lo que la operación se aborta. 

El comportamiento descrito es correcto, y, efectivamente, se debe a que a un terminal con un 'runtime' de una cierta versión no se le puede cargar de manera directa (via USB, ethernet, etc) una aplicación con una versión de 'runtime' anterior. La solución pasa por utilizar una CF (tarjeta de memoria Compact Flash) para realizar ésta carga. El procedimiento en éste caso es:
1- Mediante el Vijeo Designer v4.6 cargar la aplicación a la CF (seleccionar descarga a sistema de archivos y seleccionar la ruta de la CF).
2- Insertar la CF en el terminal, estando éste sin tensión; dentro del compartimento de la CF, habilitar el interruptor SW1 (dip switch); estando éste interruptor habilitado, se fuerza que ante una puesta en tensión, la aplicación se cargue desde la CF, y no desde la RAM del dispositivo.
3- Poner en tensión el equipo; se ha de cargar la aplicación con el 'runtime' v4.6.
Recordar de deshabilitar el interruptor anteriormente habilitado, si fuese necesario.
FA31038  |  05-abr-2011  | Programación
Por favor calificar el contenido de esta informacion
No fue útil 1 2 3 4 5 Fue útil
Que podemos hacer para mejorar esta informacion?
 
Su dirección de correo electronico